Results 1 to 1 of 1

Thread: QT app running on MacOS gives error

  1. #1
    Join Date
    Apr 2018
    Qt products
    MacOS X Unix/X11

    Post QT app running on MacOS gives error

    I created a GUI app on MacOS, which is running well if I just use QT Creator build the project and run with the green triangle (Run). However, after the app is generated, if I run the app from the build directory, it cannot run when I double click that app, and gives an error message as the figure below:

    If I click the "Reopen" button in the warning box, the app will start and run correctly. Both debug and release give the same result.

    I also tried this app on Ubuntu system; the app runs correctly for all cases.

    Could you please give me some hint about this problem? Thanks!

    Mac OS: 10.12.6, QT Version: 5.9.2.
    Last edited by LTR; 19th April 2018 at 05:09. Reason: typo

Similar Threads

  1. Error while running on arm
    By UrATowelie in forum Newbie
    Replies: 1
    Last Post: 2nd October 2017, 18:49
  2. Replies: 2
    Last Post: 3rd May 2017, 07:32
  3. Replies: 4
    Last Post: 6th March 2014, 05:57
  4. error while running
    By sattu in forum Newbie
    Replies: 7
    Last Post: 11th January 2011, 12:42
  5. running error
    By Mysterious in forum Newbie
    Replies: 1
    Last Post: 3rd November 2007, 12:53


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.