I'm creating a Qt project and receiving the following error in the Application output when running in the release mode:

Qt Code:
  1. Starting /Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Debug/my_project ...
  2. Failed to start program. Path or permissions wrong?
  3. /Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Debug/my_project exited with code -1
  4. The process failed to start. Either the invoked program "/Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Debug/my_project" is missing, or you may have insufficient permissions to invoke the program.
To copy to clipboard, switch view to plain text mode 

compile output:

Qt Code:
  1. Running steps for project my_project...
  2. Configuration unchanged, skipping qmake step.
  3. Starting: "/usr/bin/make" -j4
  4. make: Nothing to be done for `first'.
  5. The process "/usr/bin/make" exited normally.
  6. Elapsed time: 00:00.
To copy to clipboard, switch view to plain text mode 

The same happens in debug mode.

Current Configurations:
Mac clang_64(Mac OS Sierra, version 10.12.6)
Qt 5.6.3
Qt Creator 4.10.1

How i'm creating the project:
  • new project -> Qt Widgets Application
  • build system: qmake
  • kit selection: Desktop Qt 5.6.3 clang 64bit2

My current project settings:

build settings -> general:
shadow build is checked
build directory: /Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Release

run settings -> run:
executable: /Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Release/my_project
working directory: /Users/user/projects/build-my_project-Desktop_Qt_5_6_3_clang_64bit2-Release/my_project.app/Contents/MacOS

In the executable field of run settings, my_project doesn't have the .app extension. Could this mean something with the qt not finding my_project?