Results 1 to 11 of 11

Thread: IBASE driver not found ?

  1. #1
    Join Date
    Apr 2007
    Location
    Sunny Darwin, NT Australia
    Posts
    186
    Thanks
    29
    Thanked 5 Times in 5 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default IBASE driver not found ?

    I'm experimenting with the sqlbrowser example and when I run the app, my firebird (QIBASE) driver doesn't appear in the combo box.
    Does this indicate Qt can't find the driver ?
    I've installed the sql plugin as per the documentation, and I'm pretty sure it's right, but don't know how to check this.

  2. #2
    Join Date
    May 2006
    Posts
    788
    Thanks
    49
    Thanked 48 Times in 46 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    I'm experimenting with the sqlbrowser example and when I run the app, my firebird (QIBASE) driver doesn't appear in the combo box.
    Does this indicate Qt can't find the driver ?
    I've installed the sql plugin as per the documentation, and I'm pretty sure it's right, but don't know how to check this.
    this must you explain on installation from QT..

    ./configure with -qt-sql-qibase ....

    http://www.google.ch/search?q=qt-sql...nG=Cerca&meta=

  3. #3
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    5,372
    Thanks
    28
    Thanked 975 Times in 912 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    Does this indicate Qt can't find the driver ?
    Most likely, yes.

    Quote Originally Posted by vieraci View Post
    I've installed the sql plugin as per the documentation
    Where did you copy the plugin exactly? What does ldd output when you run it on the plugin?

  4. #4
    Join Date
    Apr 2007
    Location
    Sunny Darwin, NT Australia
    Posts
    186
    Thanks
    29
    Thanked 5 Times in 5 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: IBASE driver not found ?

    To get the plugin, I had to download the source for Qt4 from Trolltech and compile it.
    The install phase copied the plugins and drivers automatically to:

    /usr/local/Trolltech/Qt-4.2.3/plugins/sqldrivers

    ldd on the file libqsqlibase.so:

    linux-gate.so.1 => (0xffffe000)
    libfbclient.so.2 => /usr/lib/libfbclient.so.2 (0xb7e8a000)
    libQtSql.so.4 => /usr/local/Trolltech/Qt-4.2.3/lib/libQtSql.so.4 (0xb7e52000)
    libQtCore.so.4 => /usr/local/Trolltech/Qt-4.2.3/lib/libQtCore.so.4 (0xb7cd2000)
    libz.so.1 => /lib/libz.so.1 (0xb7cbf000)
    libgthread-2.0.so.0 => /opt/gnome/lib/libgthread-2.0.so.0 (0xb7cb9000)
    libglib-2.0.so.0 => /opt/gnome/lib/libglib-2.0.so.0 (0xb7c24000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb7c0c000)
    libdl.so.2 => /lib/libdl.so.2 (0xb7c08000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b24000)
    libm.so.6 => /lib/libm.so.6 (0xb7afe000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7af1000)
    libc.so.6 => /lib/libc.so.6 (0xb79c3000)
    libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7905000)
    libncurses.so.5 => /lib/libncurses.so.5 (0xb78be000)
    librt.so.1 => /lib/librt.so.1 (0xb78b5000)
    /lib/ld-linux.so.2 (0x80000000)

    If it's important, QTDIR is pointing to /usr/lib/qt3

    If I try to run qtconfig I get the GUI which doesn't seem to have any PATH settings, only settings for my projects.
    Last edited by vieraci; 20th May 2007 at 02:37. Reason: updated contents

  5. #5
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    5,372
    Thanks
    28
    Thanked 975 Times in 912 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    To get the plugin, I had to download the source for Qt4 from Trolltech and compile it.
    Do you have another copy of Qt4 installed?

    Quote Originally Posted by vieraci View Post
    libfbclient.so.2 => /usr/lib/libfbclient.so.2 (0xb7e8a000)
    So it looks that the linker can find the Firebird libraries.

    Check where Qt looks for the plugins with strace:
    strace ./sqlbrowser 2>&1 | grep plugins

  6. #6
    Join Date
    Apr 2007
    Location
    Sunny Darwin, NT Australia
    Posts
    186
    Thanks
    29
    Thanked 5 Times in 5 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: IBASE driver not found ?

    Quote Originally Posted by jacek View Post
    Do you have another copy of Qt4 installed?
    Yes, Qt3 and Qt4 form original install.

    Quote Originally Posted by jacek View Post
    So it looks that the linker can find the Firebird libraries.
    Check where Qt looks for the plugins with strace:
    nothing...

  7. #7
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    5,372
    Thanks
    28
    Thanked 975 Times in 912 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    Yes, Qt3 and Qt4 form original install.
    Is your application linked against the original Qt4 or the one you have compiled recently?

  8. #8
    Join Date
    Apr 2007
    Location
    Sunny Darwin, NT Australia
    Posts
    186
    Thanks
    29
    Thanked 5 Times in 5 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: IBASE driver not found ?

    Quote Originally Posted by jacek View Post
    Is your application linked against the original Qt4 or the one you have compiled recently?
    I don't know...How do I find out ?
    Last edited by vieraci; 21st May 2007 at 15:05.

  9. #9
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    5,372
    Thanks
    28
    Thanked 975 Times in 912 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    How do I find out ?
    For example with ldd.

  10. #10
    Join Date
    Apr 2007
    Location
    Sunny Darwin, NT Australia
    Posts
    186
    Thanks
    29
    Thanked 5 Times in 5 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: IBASE driver not found ?

    Quote Originally Posted by jacek View Post
    For example with ldd.
    Looks like the previously installed version.

    ldd sqlbrowser
    linux-gate.so.1 => (0xffffe000)
    libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0xb7e8a000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xb77b8000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7794000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xb778a000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xb7770000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xb7767000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb775e000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7759000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7753000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7749000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb7744000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb76d8000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb76ad000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xb769e000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xb7581000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xb7402000)
    libz.so.1 => /lib/libz.so.1 (0xb73ef000)
    libdl.so.2 => /lib/libdl.so.2 (0xb73eb000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb73d3000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb72ef000)
    libm.so.6 => /lib/libm.so.6 (0xb72c9000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb72bc000)
    libc.so.6 => /lib/libc.so.6 (0xb718e000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7188000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xb7184000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7162000)
    /lib/ld-linux.so.2 (0xb7eef000)

    The newer install is at
    /usr/local/Trolltech/Qt-4.2.3/lib

  11. #11
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    5,372
    Thanks
    28
    Thanked 975 Times in 912 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: IBASE driver not found ?

    Quote Originally Posted by vieraci View Post
    Looks like the previously installed version.

    ldd sqlbrowser
    linux-gate.so.1 => (0xffffe000)
    libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0xb7e8a000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xb77b8000)
    Yes, in such case Qt might not want to load any plugins from the newer version because of mismatching build keys.

    Recompile your application using the new Qt version. If you use qmake, simply run qmake from /usr/local/Trolltech/Qt-4.2.3/bin on your .pro file, then "make clean" and "make".

  12. The following user says thank you to jacek for this useful post:

    vieraci (22nd May 2007)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.