Results 1 to 5 of 5

Thread: qwt designer build errors

  1. #1
    Join Date
    Jun 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Qt products
    Qt3 Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default qwt designer build errors

    Win32, XP, QT open source vers.
    QWT 5.0.2 with QT4.
    Nmake gets stuck on building qwt designer:
    Tried also using msvc project, instead of makefile, but still get unresolved external symbol errors (lots). Not sure what it's missing?


    qwt_designer_plugin error LNK2001: unresolved external symbol "__declspec(dllimport) public: static struct QMetaObject const QwtDial::staticMetaObject" (__imp_?staticMetaObject@QwtDial@@2UQMetaObject@@B )
    qwt_designer_plugin error LNK2001: unresolved external symbol "__declspec(dllimport) public: static struct QMetaObject const QwtPlot::staticMetaObject" (__imp_?staticMetaObject@QwtPlot@@2UQMetaObject@@B )
    qwt_designer_plugin error LNK2001: unresolved external symbol "private: virtual double __thiscall QwtKnob::getValue(class QPoint const &)" (?getValue@QwtKnob@@EAENABVQPoint@@@Z)
    ....etc.

    QT4 seems working fine, environment variables set, etc.
    Have qwtconfig.pri set to install in same folder as sources.
    Thank You.

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: qwt designer build errors

    Which exact version of Qt? What changes exactly were applied to qwtconfig.pri?
    J-P Nurmi

  3. #3
    Join Date
    Jun 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Qt products
    Qt3 Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: qwt designer build errors

    qt-win-opensource-4.2.3 (msvc build)
    qwt-5.0.2
    WinXP pro, msvc .NET 2003
    -----
    changes to qwtconfig.pri:

    Moved unzipped sources (Qwt-5.02 to Temp)
    modified INSTALLBASE to point to local directory ex. C:/Temp/QWT-5.0.2 and install libs in source folder.

    # Install paths
    win32 {
    INSTALLBASE = C:/Qwt-5.0.2
    }
    ----
    QWT build gets stuck on qwt designer with unresolved external symbol errors. Seems like it's not finding something it needs. Not sure what it's looking for.


    Thanks.

  4. #4
    Join Date
    Jun 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Qt products
    Qt3 Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: qwt designer build errors

    Also tried QWT with MSVC build of QT4.3.0. Tried QWT 5.0.1, and 5.0.2. Tried generating MSVC projects for building, and also using nmake.

    Still getting unresoved external symbol errors...

    qwt_designer_plugin.obj : error LNK2001: unresolved external symbol "protected:
    virtual void __thiscall QwtPlot:rintLegend(class QPainter *,class QRect const
    &)const " (?printLegend@QwtPlot@@MBEXPAVQPainter@@ABVQRect@@ @Z)
    etc.

  5. #5
    Join Date
    Jun 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Qt products
    Qt3 Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: qwt designer build errors

    Switched to Vista and QWT. Still getting build errors. Using qmake and decommenting the option to build examples it claims it cannot find uuic.lib, which is located in the sdk, not in msvc.

    O.K. Recommented the examples and tried again. Get the qwt4.lib, and qwt5.dll, but no examples, so tried building vcprojs of examples and pointing each project towards uuic.lib in the msvc project settings.

    Works sort of, but get "file corrupt" error on qwt5.dll.

    Alright then forget qwt on windows.

    (Good news is, I think it's working on Linux)

Similar Threads

  1. QWT fails in debug build
    By steg90 in forum Qwt
    Replies: 1
    Last Post: 11th November 2011, 07:53
  2. Replies: 4
    Last Post: 10th October 2009, 18:59
  3. Build error on mac Platform::WaitMouseMoved
    By patrik08 in forum Qt Programming
    Replies: 1
    Last Post: 12th July 2007, 14:18
  4. Build errors on YDL 4.0.1
    By milonguero in forum Installation and Deployment
    Replies: 0
    Last Post: 19th April 2007, 21:54

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.