Results 1 to 9 of 9

Thread: Failure to build Debug libs - Vista Mingw Qt 4.3.2

  1. #1
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Failure to build Debug libs - Vista Mingw Qt 4.3.2

    Hi
    I was searching the threads hoping to find an answer , some came close ...

    my INCLUDE and LIB are both Empty;
    I Installed via the Binary Pack , trying to build debug libs for use in Eclipse.

    I tried to put Mingw\include in the INCLUDE but that just made it worse , this
    is the base error I get .

    I am using the Qt Build Debug bat, I have tried to build with -no-zlib , but it just errors out later on telling me it can't find winver.h.

    Any help would be greatly appreciated.

    Patrick

    set QTDIR=C:\Qt\4.3.2
    set PATH=C:\Qt\4.3.2\bin
    set PATH=%PATH%;D:\MinGW\bin;D:\MinGW\libexec\gcc\ming w32\3.4.2
    set PATH=%PATH%;%SystemRoot%\System32
    set QMAKESPEC=win32-g++

    In file included from ..\..\3rdparty\zlib\crc32.c:29:
    ..\..\3rdparty\zlib\/zutil.h:21:24: stddef.h: No such file or directory
    ..\..\3rdparty\zlib\/zutil.h:23:22: string.h: No such file or directory
    ..\..\3rdparty\zlib\/zutil.h:24:22: stdlib.h: No such file or directory
    ..\..\3rdparty\zlib\/zutil.h:38:23: errno.h: No such file or directory
    ..\..\3rdparty\zlib\crc32.c:36:24: limits.h: No such file or directory
    mingw32-make[2]: *** [tmp\obj\release_shared\crc32.o] Error 1
    mingw32-make[2]: Leaving directory `C:/Qt/4.3.2/src/tools/rcc'
    mingw32-make[1]: *** [release] Error 2
    mingw32-make[1]: Leaving directory `C:/Qt/4.3.2/src/tools/rcc'
    mingw32-make: *** [debug-C__Qt_4_3_2_src_tools_rcc] Error 2
    C:\Qt\4.3.2\src>

  2. #2
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    495
    Thanked 73 Times in 69 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    D:\MinGW\libexec\gcc\ming w32\3.4.2 is wrong. Remove it and try again.

  3. #3
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    will do , but I am sure it's going to tell me , CC1 not found .

    Thanks hope it works

  4. #4
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    495
    Thanked 73 Times in 69 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    Ok, then you've the 'classic' mingw on vista problem. You have to update your mingw runtime. Download it from sf.net/projects/mingw (Download section, 'mingw runtime') and unpack it to your mingw install dir.
    See also mingw-users mailing list about the discussion using mingw/vista.

  5. #5
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    Will do thanks so much for your help!

  6. #6
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    mingw-runtime-3.13.tar is this the correct one ?
    Thanks .

  7. #7
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    Qt is now configured for building. Just run mingw32-make.
    To reconfigure, run mingw32-make confclean and configure.

    (cd C:\Qt\4.3.2\src\winmain && mingw32-make -f Makefile debug)
    mingw32-make[1]: *** No rule to make target `debug'. Stop.
    mingw32-make[1]: Entering directory `C:/Qt/4.3.2/src/winmain'
    mingw32-make[1]: Leaving directory `C:/Qt/4.3.2/src/winmain'
    mingw32-make: *** [debug-C__Qt_4_3_2_src_winmain] Error 2
    C:\Qt\4.3.2\src>

    this is what I got

    Thans again .

  8. #8
    Join Date
    Jan 2006
    Location
    Bremen, Germany
    Posts
    495
    Thanked 73 Times in 69 Posts
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    What configure options did you use? Looks like you added '-debug' or '-release' which is not good on windows. Maybe post configure.exe output.
    Try "..\..\bin\qmake -spec win32-g++" in src\winmain to regenerate Makefiles in there.

  9. #9
    Join Date
    Sep 2007
    Posts
    20
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Failure to build Debug libs - Vista Mingw Qt 4.3.2

    Thanks so much for your help Christian!

    I got it!

    How are you in Eclipse


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.